HDS Not Responding -> Error 121 The semaphore timeout expire

How, what, where and why - when using the software.

HDS Not Responding -> Error 121 The semaphore timeout expire

Postby Written7 » 2020.02.23. 12:15

Hello together :)
I bought two new HDD's and wanted to make some test before I use them. The Disks are WD Gold 14TB and are attached for testing over a USB3.0 HDD Docking Station to a Laptop with Win10 x64.
With HDS I run the extended SMART test on both HDD's simultaneously with no problems everything went smooth, it took just a long time but that's because the capacity.
After that I started the Surface Write + Read Test on both HDD's simultaneously. Until about 50 percent of the tests I looked fine, after that I got some errors like:
Error 121 The semaphore timeout period has expired., Sector X, Block X.

I'm not sure if this is a problem with the Disks or the program or something else.
Does anybody has any ideas?

I've uploaded a screenshot of these errors as attachment.
Attachments
HDS_Surface_Test.png
Screenshot of both surface tests with error message.
HDS_Surface_Test.png (145.13 KiB) Viewed 4156 times
Written7
 
Posts: 2
Joined: 2020.02.16. 16:34

Re: HDS Not Responding -> Error 121 The semaphore timeout ex

Postby hdsentinel » 2020.02.24. 13:27

No, I can confirm that it is not a problem with the software and may not related to the disk drive (if the disk drive is 100% healthy and the extended test did not show any problems).

The problem is likely the USB adapter/docking station/enclosure itself which works "between" the computer and the WD Gold hard disk drive.

There is good chance that the docking station (more precisely its USB-ATA bridge chip) overheats during an excessive data transfer caused by read/write commands for so long time (as I see on the image, 60 hours). When this chip "stuck" then it does not respond for the operating system. As a result, Windows may issue a timeout error (as you can see) and any software/applications (Hard Disk Sentinel in this case ;) ) also does not receive any response from the device, so the software seems "not responding" as it is waiting for the disk drive.
It is completely normal and expected in this case I'm afraid.

If possible, maybe you can try
- add extra cooling for the USB docking station. Some users placed notebook cooling pad below the USB docking station / external drive to make additional airflow which can help to make stable operation
- make smaller tests: instead of testing the whole drive at once, you can try to test only (for example) 1/4 area of the disk at once to prevent too much stress of the docking station. For this, please select Disk menu -> Surface test, the proper test type and drive and before starting the test, select the Configuration tab. There you can select the Limit testing to specific data blocks and specify the First block / Last block values.
For example, if you set First block = 0, last block = 2499, then the test will process the first 1/4 only.
Then First block = 2500, last block = 4999, then the test will process the second 1/4 only.
and so.

The Disk menu -> Extended self test is different: it runs "inside" the hard disk drive: Hard Disk Sentinel starts the test, reads the progress and results only. As it does not cause TB's of data transferred via the mentioned USB chip, it does not cause overheat - this is why there were no problems in that case.
This is exactly why it may be good option to test both ways: by the Extended self test, we can verify the drive "internals" and by the surface test, we can verify even other components in the storage chain (eg. USB adapter/docking station) too.
User avatar
hdsentinel
Site Admin
 
Posts: 2325
Joined: 2008.07.27. 17:00
Location: Hungary

Re: HDS Not Responding -> Error 121 The semaphore timeout ex

Postby Written7 » 2020.04.15. 09:43

Thanks for your detailed answer. And sorry for my late feedback, a few more important things came up...

I did another test, connected to another computer directly with SATA on the mainboard, so without a docking station.
There were no problems there, the test went through completely and without any problems.

The problem was as you suspected, the docking station. :)
Written7
 
Posts: 2
Joined: 2020.02.16. 16:34


Return to Questions

Who is online

Users browsing this forum: No registered users