Page 1 of 1

Not all NVMe SSDs in VROC array are visible

PostPosted: 2019.10.30. 16:44
by Gagome
Hello,

I searched for a product which is able to show me the temparature of my NVMe SSDs which are members of Intel VROC arrays.
And I found HDS version 5.50. In the revision history log I saw that this version should support NVMe RAID array members.
But it doesn't seem to work 100% correct.

I have a Lenovo P920 and there are total 3 VROC arrays. One is RAID1 and the other two RAID10.
In total I have 10 NVMe SSDs installed. All are members of VROC arrays and all are SAMSUNG PM981.

HSD version 5.50 only shows 6 NMVe members.
Why only 6?
What about the other 4?

Is there a limit how many NVMe SSDs HSD is able to detect?

Additionally I have 6 "non-SSD" harddisks attached to an Adaptec RAID controller. All 6 are detected by HSD.
And another SSD disk (non-RAID) is attached to the PC.
This makes total 17 harddisks.
HSD only detects 14.
4 NVMe SSD disks are missing.
Is 14 disks a limit in HSD?

Is this probably a bug? Or a limit of the non-registered version?
I would buy HSD when it fully works.

Thanks.

Attached is a screenshot of Intel VROC Device list and a screenshot of HSD Hard Disk Drives list.
HSD only sees 6 SAMSUNG NVMe drives.

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2019.10.31. 10:11
by hdsentinel
Thanks for your message.

No, I can confirm that there are no limits in Hard Disk Sentinel, especially not a trial/unregistered limitation.
The trial/unregistered version designed exactly to verify and confirm hardware compatibility.

As VROC is a relatively new area and it is impossible to reproduce all different configurations/combinations, it is possible that currently some disks may be missing. Personally had no opportunity to test with 10 NVMe SSDs on VROC controller yet.
Good to hear that many of the SSDs could be detected correctly and good to hear that disk drives on the Adaptec controller also detected as should.

To investigate why some SSDs missing and improve the situation, please

1) open Configuration -> Send test report page.
2) use the Create test report to create and then save a developer-report in text file
3) send that developer-report to info (at) hdsentinel (dot) com address.

This way it is possible to examine specifically the "raw" response of the VROC controller and improve the detection for this specific situation, to extend the detection for more SSDs.
From this developer-report, I suspect an updated version can be made quickly.

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2019.10.31. 11:53
by Gagome
Thanks for your reply.

I have now created a Test Report and I have sent it to you.
Hopefully you can see what is wrong and fix it.

Thanks.

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2019.11.11. 18:47
by Gagome
Hello,

Any news?
Have you received the report?
Did you see anything which can be corrected?

Thanks.

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2019.11.12. 09:37
by hdsentinel
Yes, I received the report, thanks!
Still working on it. Seems the VROC driver does not respond as should in your case, so trying to verify the situation and make changes.
Will send updated version soon, surely in some days.
Thanks for your patience.

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2020.02.26. 19:45
by fkehren20
I have the same problem in a VROC RAID 0 with 16 SSDs - it shows only 6 of the SSDs. All SSDs are Samsung PM981.
Any news regarding a fix?

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2020.02.26. 19:56
by hdsentinel
There was an update already finished, the 5.60 version attempts to detect additional NVMe SSDs on VROC controller.

Not sure if you use that version, if so, please use Report menu -> Send test report to developer option as then I can check the "raw" response of the controller and investigate the possibilities about further modifications.

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2020.04.28. 20:28
by fkehren
hdsentinel wrote:There was an update already finished, the 5.60 version attempts to detect additional NVMe SSDs on VROC controller.

Not sure if you use that version, if so, please use Report menu -> Send test report to developer option as then I can check the "raw" response of the controller and investigate the possibilities about further modifications.

I have tried version 5.61 in the meantime and it shows 10 of my 16 SSDs. I'm attaching a screenshot and the disk report.

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2020.04.28. 20:51
by hdsentinel
Thanks for the image and the file, but I'm afraid that does not help as it does not contain the details...

As I wrote, please use Report menu -> Send test report to developer option as then I can check the "raw" response of the controller and investigate the possibilities about further modifications.
The user level report shows the current status - but does not give any details about what can be checked, examined, modified (which depends on the raw response of the controller during the detection).

Alternatively, you may select Configuration -> Send test report page, where you can create and save this developer-report for manual sending.

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2020.04.28. 22:04
by fkehren
the computer is not on a network - so can't send directly. Attached is the file with the developer report.

Re: Not all NVMe SSDs in VROC array are visible

PostPosted: 2020.04.29. 11:38
by hdsentinel
Thanks for the file.
I'm checking and will send updated version for testing as soon as possible.
Thanks for your help and increasing attention to this situation.