Page 1 of 1

Degree character not displayed correctly

PostPosted: 2020.01.22. 06:34
by ckp
Hi

Not sure of how this has occurred however the "degree" symbol shown with the temperature is being displayed as a question mark inside a black diamond. Issue is the same for Fahrenheit and Celsius and is also being displayed incorrectly anywhere a temperature is displayed.

I have also uninstalled HDS and re-installed again but no change. Is there a font somewhere inside HDS that may have got corrupted?

Re: Degree character not displayed correctly

PostPosted: 2020.01.22. 08:26
by hdsentinel
Seems so interesting. Maybe related to Windows language/regional setting. Not sure if it may be changed recently (if things were working correctly previously?)

Can you please use Report menu -> Send test report to developer option? Then it is possible to check the actual system setting and try to reproduce and improve the situation in all possible ways.

Re: Degree character not displayed correctly

PostPosted: 2020.01.22. 17:03
by ckp
so thanks for the hint - remembered I had made a minor change to the Administrative section of the regional settings.

I had selected the Beta: Use unicode tick box as per the attachment. Once I un-ticked this option problem was solved.

Thanks

Re: Degree character not displayed correctly

PostPosted: 2020.01.23. 11:11
by hdsentinel
Thanks for increasing attention to this option!
I'm checking how it affects the display and examine how things can be changed, improved to prevent incorrect character display even if enabled.
Thanks!