LSI 9305-24i

Experiences with hard disks, SSDs, USB devices, hard disk controllers, motherboards and so.

LSI 9305-24i

Postby Y0tsuya » 2017.01.23. 11:53

I just installed a LSI 9305-24i HBA. HD Sentinel can't seem to get through to the drives when using this adapter.
Y0tsuya
 
Posts: 13
Joined: 2009.10.09. 22:35

Re: LSI 9305-24i

Postby hdsentinel » 2017.01.23. 14:35

Sounds interesting as generally Hard Disk Sentinel supports such and similar LSI controllers.
Which version do you use? I'd recommend to try the latest 4.71.10 which (as all new versions always) have improved support for newest hardware.
I'd recommend to use Report menu -> Send test report to developer option with that, so then it is possible to check what happens, what is the "raw" response of the controller and examine the possibilities.
User avatar
hdsentinel
Site Admin
 
Posts: 2299
Joined: 2008.07.27. 17:00
Location: Hungary

Re: LSI 9305-24i

Postby Y0tsuya » 2017.01.23. 19:59

I was using 4.10 but did install the latest just to see. Same result though.

I've just sent a report.
Y0tsuya
 
Posts: 13
Joined: 2009.10.09. 22:35

Re: LSI 9305-24i

Postby hdsentinel » 2017.01.24. 12:29

Thanks, I see!
4.10 was too old for these newer controllers, generally newer versions required for newer hardware in order to support them.

Yes, from the new report I see the situation: when the controller accessed, it responds with generic information only but there is no real details about the drives. Really weird, as with SAS9300-8i tested, there were no such problems / issues.

Not sure, but it is possible that the problem may be related to backplane / SAS expander used for the SATA hard disks, as this may block accessing the disk status information. Do you use any special such SAS explander / backplane?

Trying to perform further researching about the possibilities....
Thanks for your attention, I'll let you know any new, updates!
User avatar
hdsentinel
Site Admin
 
Posts: 2299
Joined: 2008.07.27. 17:00
Location: Hungary

Re: LSI 9305-24i

Postby Y0tsuya » 2017.01.24. 19:41

Hi the backplane is passive Norco stuff. I've previously used those with a 3ware 9650se-24ml. I changed from 9650se to 9305 because it won't recognize the newer Ironwolf 10TB drives. I also tried plugging in a WD Red 6TB which the 9650se can recognize, but still same result on 9305.

So the combinations I tried:

9650se->backplane->WD Red works
9305->backplane->Ironwolf doesn't work
9305->backplane->WD Red doesn't work

So yes this is very strange because as a HBA it's not supposed to block anything. However the 9305-24i is using the SAS3224 IOC while 9300-8i is using the SAS3008 IOC so there's some difference.
Y0tsuya
 
Posts: 13
Joined: 2009.10.09. 22:35

Re: LSI 9305-24i

Postby Y0tsuya » 2017.05.04. 12:14

Any updated on this?

BTW I got a Areca ARC-1883i, it recognizes my 6TB WD Reds.
Y0tsuya
 
Posts: 13
Joined: 2009.10.09. 22:35

Re: LSI 9305-24i

Postby hdsentinel » 2017.05.05. 10:22

Please check with latest 5.01 version.
This has generic improvements and changes for LSI controllers (too). Please use Report menu -> Send test report to developer option with it - as then it is possible to check the results and if things are still not correct, maybe it can help in further development.

Yes of course, the detection depends on the controller, firmware, driver etc... completely independent from the drive itself.
User avatar
hdsentinel
Site Admin
 
Posts: 2299
Joined: 2008.07.27. 17:00
Location: Hungary

Re: LSI 9305-24i

Postby Y0tsuya » 2017.05.05. 20:44

Report sent using 5.0.1. Same thing. Drives show up but no much in the way of SMART data.
Y0tsuya
 
Posts: 13
Joined: 2009.10.09. 22:35

Re: LSI 9305-24i

Postby hdsentinel » 2017.05.07. 13:06

Thanks !

Yes, I see, and I'm sorry about the results.
In the new version new techniques added for this controller, but seems these do not help.

The disk controller provides only limited set of information so the drives can be identified - but the appropriate commands to access S.M.A.R.T. information blocked.
This is weird because there should be no problems in general with LSI controllers.

Will keep reseaching and asking the manufacturer (as did previously) as hopefully there will be a solution - but this depends on them too.
User avatar
hdsentinel
Site Admin
 
Posts: 2299
Joined: 2008.07.27. 17:00
Location: Hungary


Return to Supported Hardware

Who is online

Users browsing this forum: No registered users