After wake up from hibernate HDS is mostly dead

Post here if you encounter any problems or bugs with the software.

After wake up from hibernate HDS is mostly dead

Postby Gagome » 2021.04.03. 15:28

Hello,

I am using HDS version 5.70.2. Usually I hibernate my desktop PC when I am not using it. Unfortunately HDS doesn't seem to like that.
Sometimes after I wake the PC up from hibernation HDS can't be opened anymore. This doesn't happen every time I use hibernate and wake up.
When this problem occurs the icons with the temperature for each harddisk are still in the notification area and when I hover the mouse over them I see all the information about the disk from HDS. But the values are no longer changing. And when I right click on the notification icon nothing is happening. When I try to open HDS clicking on the icon on the desktop again nothing is happening. HDS is practically dead.
In this situation only a reboot will bring it back.
The HDS task cannot be killed from the taks manager or process explorer. In process explorer the HDS taks has the status "Not responding".
When I try to kill it from process explorer nothing is happening.

OS is Win10 x64 20H2 (OS Build 19042.870).
I am using two RAID10 arrays on Intel VROC and one RAID5 array on Adaptec 8885Q raid controller.
All disks are visible and HDS is working great when it is not dead.

What can I do to debug this problem?
What additional information do you need?

BTW: I encountered this problem in all the versions 5.61.x and 5.70.x.
Gagome
 
Posts: 6
Joined: 2019.10.30. 16:16

Re: After wake up from hibernate HDS is mostly dead

Postby hdsentinel » 2021.04.04. 10:52

Thanks for your message.
Sorry for the possible troubles, but I can confirm that NO, HDS is absolutely not "dead".

Hard Disk Sentinel is still running and after wake up, it attempts to detect the configuration, exactly to provide updated values for all disk drives.
If you see it is "not responding" and everything you wrote is related to one or more disk drives and/or disk (RAID) controllers which do not respond as should. Then Hard Disk Sentinel is (as expected) waiting for the devices - but it seems in your case something is no longer responding at all, causing that Hard Disk Sentinel needs to wait.

Not sure if your VROC or the Adaptec RAID is causing the problem. Yes, generally they should work correctly with Hard Disk Sentinel and personally never encountered similar with them. Maybe their combination and/or some disk(s) can cause the troubles.

I suggest to please use Report menu -> Send test report to developer option when things are working correctly. Checking the situation can help and give ideas / thoughts and we can narrow things, to verify which controller / disk can be the source of the problem.
User avatar
hdsentinel
Site Admin
 
Posts: 2547
Joined: 2008.07.27. 17:00
Location: Hungary

Re: After wake up from hibernate HDS is mostly dead

Postby Gagome » 2021.04.04. 13:20

Thanks for your reply.

When HDS is not dead why can it not be killed with Process Explorer?

With older versions of HDS (I don't remember exactly which versions but I believe some 5.50.x and 5.61.x versions) I encountered a similar problem that after a reboot HDS started but HDS didn't display anything. No notification icons. And when I try to start HDS from the desktop nothing was happening. And similar to now the HDS task couldn't be killed using the Process Explorer. All I was able to do is reboot. And when the problem reoccured I had to reboot again. Sometimes three times.
That was annoying.
With version 5.70.x this problem didn't occur yet. But it basically occurs after hibernate.
And an upgrade to a new version was not possible when this problem occured. Because the new version was not able to kill the running HDS process and update the main exe file.

Why is it not possible to kill the HDS process?

Anyway, when I reboot (I usually do this only once in a month) I will send a test report to developer. Hopefully, you can find something which can be further analyzed.

You say that HDS is waiting for a device. But all disks are fully functional. When I open the Intel VROC GUI all disks are visible and in a normal state. When I open Adaptec maxView Storage Manager again every disk is in optimal state. Everything is OK. So, I wonder for what device HDS is waiting for?
Gagome
 
Posts: 6
Joined: 2019.10.30. 16:16

Re: After wake up from hibernate HDS is mostly dead

Postby hdsentinel » 2021.04.05. 11:01

Everything you wrote related to 100% same background: Hard Disk Sentinel started, attempted to access the disks/controllers and detect the status information. It needs to wait for the devices - and if there is no response, you may see what you wrote:

> HDS started but HDS didn't display anything. No notification icons.
> And when I try to start HDS from the desktop nothing was happening.
> And similar to now the HDS task couldn't be killed using the Process Explorer.

This is completely independent from Hard Disk Sentinel. Hard Disk Sentinel does not "protect" itself of course: during normal operation, it can be any time "killed" from Task Manager if really required. If it is not possible - then it means some device is "locking" the software which attempted to access it - Hard Disk Sentinel in this case.

It is completely independent from the versions - expect that older versions of HDS may not support the newest hardware, so older versions did not attempt to detect VROC, Adaptec RAID and so. Maybe you did not see similar with old versions - exactly because they did not attempt to detect the disk status information.

> Why is it not possible to kill the HDS process?

Because a device is not responding and somehow locking the software which attempted to access it. It is completely independent from Hard Disk Sentinel but more related to the device driver.

> Anyway, when I reboot (I usually do this only once in a month)
> I will send a test report to developer. Hopefully, you can find something which can be further analyzed.

From the developer report, I'd surely see things more clearly. Actual disk configuration, the drivers used for the controller(s) can give ideas, thoughts and by that, it is possible to examine if
- a driver update
- or some changes in the software
can help to minimise issues.

> You say that HDS is waiting for a device. But all disks are fully functional.
> When I open the Intel VROC GUI all disks are visible and in a normal state.
> When I open Adaptec maxView Storage Manager again every disk is in optimal state.
> Everything is OK.

It does not mean anything. It only means that at a LATER stage the disks/controllers work properly - but not immediately after wake up.
I'm sure the same would happen if you'd manually close Hard Disk Sentinel before hibernation and then later restart it manually after wake up, when the disks/controllers are already working/responding properly.
Maybe it is only a question time: HDS may need to apply some delay on wake up before attempting to detect/update the status. Probably it happens too quickly after wake up on your system.

> So, I wonder for what device HDS is waiting for?

I'm so curious about it too. The developer report can help to check and also we can examine the behaviour specifically for your RAID controllers/disks.
User avatar
hdsentinel
Site Admin
 
Posts: 2547
Joined: 2008.07.27. 17:00
Location: Hungary

Re: After wake up from hibernate HDS is mostly dead

Postby Gagome » 2021.04.07. 14:06

Thanks for your detailed reply.
I think I understand the problem now.
Maybe your suggestion to add some kind of delay after wake-up would probably solve this problem.

Anyway, I have now rebooted and HDS started correctly.
I have sent the test developer report.

Hopefully you will find some clues.

Thanks.
Gagome
 
Posts: 6
Joined: 2019.10.30. 16:16


Return to Bug Reports

Who is online

Users browsing this forum: No registered users