Missing HDD on 2nd Sata Controller

Experiences with hard disks, SSDs, USB devices, hard disk controllers, motherboards and so.

Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.07. 12:25

Hi,
I'm new to HDS but loving it! One question regarding my Desktop based on the ASUS P6T MB which has multiple SATA controllers;
- the Built-in Controller ICH10R with 6 x Sata Ports
- JMicron® JMB363 controller 1 x UltraDMA 133/100/66 for up to 2 PATA devices, 1 x eSATA 3Gb/s port(s)
- JMicron® JMB322 controller 2 x SATA 3Gb/s port(s)

As you can see from the attached pic, HDS is reporting the 5 x WDC HDD just fine (connected to the ICH10R) but the SSD (M4-CT256) which is connected to the JMB322 is not showing as a drive (this is the Main Boot Disk) in HDS but shows in Disk Mgt just fine.

Is this correct or do I need to send some logs etc?

Thanks
Nathan
Attachments
MissingHDD.png
MissingHDD.png (202.72 KiB) Viewed 34401 times
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.07. 12:48

FYI - I have sent a "Test Report"
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby hdsentinel » 2012.06.07. 13:47

Thanks, I just wanted to ask for that "Report" -> "Send test report to developer" option as it is the best way to diagnose issues.

Can you please try the latest beta version: http://www.hdsentinel.com/beta4/hdsentinel_pro_setup40011.zip

This has some improvements for JMicron devices so it is possible that the status will be detected immediately.

If possible, please "Report" -> "Send test report to developer" option in all cases with that version to check the results.
Thanks!
User avatar
hdsentinel
Site Admin
 
Posts: 2334
Joined: 2008.07.27. 17:00
Location: Hungary

Re: Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.07. 22:44

Thanks - I've sent another Test Report using the Beta and there has been some improvment! The SSD on JMIcron now detected as a drive in HDS with some "Information" now available though "Overview, Temp, SMART" are blank
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby hdsentinel » 2012.06.08. 08:00

Thanks !

Yes, I see that things are better - but the JMicron JMB363 controller still does not really want to pass complete information (as you can see).

Can you please try to update the driver of this JMicron JMB36x controller by the driver available in
Support -> Driver Zone section?

Maybe after the update (and restart) we'll see complete status, please send a new report to check the results. Thanks !
User avatar
hdsentinel
Site Admin
 
Posts: 2334
Joined: 2008.07.27. 17:00
Location: Hungary

Re: Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.08. 09:38

Done, 2 Logs sent
#1 - updated drivers = SSD still reporting little info
#2 - Moved a HDD from the Intel to the E-Sata JMicron Controller and all of it's details were avail

Let me know any combo you would like me to test.

Thanks
Nathan

PS - Great Support and Dev!
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby hdsentinel » 2012.06.08. 12:15

Thanks so much for your reports and answer !

Yes I see.
To be honest, one time we found a such issue with JMicron controller: one port provides complete hard disk (SSD) status and information but the other
did not. In that case the user swapped the hard disk with an optical drive (which was previously connected to Intel controller, he had a similar motherboard with
Intel + JMicron controllers) and the issue was corrected.

So yes, I wanted to recommend to try swapping the device(s) if possible as then the status of the SSD may be detected.

So maybe you can try to connect the SSD to Intel controller (exchange with a hard disk or optical drive).

Thanks, I know sometimes it is hard to find the best combination of devices and drivers and I try to help as much as possible. :)
User avatar
hdsentinel
Site Admin
 
Posts: 2334
Joined: 2008.07.27. 17:00
Location: Hungary

Re: Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.08. 12:33

Thanks - I'll try over the weekend - I'm currently doing a Reinitalise Disk Surface and have about 50hours to go :lol: so it may be a while before i can test!

FYI - I have found that ODD connected to the JMicron ports can not be used as a boot device either..... Not a great Sata Controller IMHO
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.17. 00:05

I have sent the report with a HDD (over SSD) on the JMicron Controller.
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby hdsentinel » 2012.06.18. 11:00

Thanks !

Yes, I checked the report and I see that now the JMicron controller blocks the status information about the HDD connected instead the SSD.
So interesting - as in theory this controller should provide complete status information about any device connected but it seems this is not the case.

Maybe can you please check if there is a firmware update available?
Otherwise I'm afraid the best may be to use a different (eg. PCI Express) controller with additional port(s) to connect the devices.
User avatar
hdsentinel
Site Admin
 
Posts: 2334
Joined: 2008.07.27. 17:00
Location: Hungary

Re: Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.18. 12:23

Thanks - Updated the JMicron driver to the latest on their web site (R1.17.63.01). I have also connected a disk to the e-sata controler which is also a JMicron controler and it is reported correctly. Sent a log if that helps.

At the end of the day I'll no longer use these sata ports.
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby hdsentinel » 2012.06.18. 12:33

Thanks!
Personally I did not see differences between the 1.17.62 and 1.17.63 driver on any systems in terms of functionality, compatibility, performance (this is why the Driver Zone lists 1.17.62 yet).

As I know, the motherboard has one JMB controller, so the internal SATA and eSATA ports belong to the same controller. This is why I personally think it is really interesting that the e-SATA port is works differently (better).

Thanks for your attention and the report!
User avatar
hdsentinel
Site Admin
 
Posts: 2334
Joined: 2008.07.27. 17:00
Location: Hungary

Re: Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.18. 13:17

Thanks - I think there are three conrollers in the P6T:

Built-in Controller :
6 x SATA 3Gb/s port(s), red
Support Raid 0, 1, 5, 10

JMicron® JMB363 controller :
1 x UltraDMA 133/100/66 for up to 2 PATA devices , red
1 x eSATA 3Gb/s port(s), red

JMicron® JMB322 controller :
1 x SATA 3Gb/s port(s), orange
1 x SATA 3Gb/s port(s), white

It is the drives connected to the JMB322 that don't report much
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby hdsentinel » 2012.06.18. 14:37

Thanks, I see !

It is interesting that on the product list of JMicron ( http://www.jmicron.com.tw/Product_list.htm )
JMB363 is listed as a PATA + SATA controller, while JMB322 is not listed at all....
User avatar
hdsentinel
Site Admin
 
Posts: 2334
Joined: 2008.07.27. 17:00
Location: Hungary

Re: Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.18. 22:37

FYI -
http://www.jmicron.com/JMB363.html
http://www.jmicron.com/JMB322.html

Both apparantly use the JMB36x driver though I see there is an e-sata driver as well (also installed from your site)
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby jmone » 2012.06.18. 22:57

For "fun" I also tried AHCI mode to see if it helped but same thing - sent a log anyway
jmone
 
Posts: 60
Joined: 2012.06.07. 12:06

Re: Missing HDD on 2nd Sata Controller

Postby hdsentinel » 2012.06.19. 12:09

Thanks !

I'm not surprised, expected the same result ;)

jmone wrote:For "fun" I also tried AHCI mode to see if it helped but same thing - sent a log anyway
User avatar
hdsentinel
Site Admin
 
Posts: 2334
Joined: 2008.07.27. 17:00
Location: Hungary

Re: Missing HDD on 2nd Sata Controller

Postby hdsentinel » 2012.06.19. 12:11

Yes, as I thought (checking the product list at JMicron) that 322 is not a new controller but a port multiplier device, which is really attached to the 363.
This is why there are no different driver required for that - but it seems it is partially working only, for example does not pass all commands (for example the commands to get disk status) to the proper hard disk.
User avatar
hdsentinel
Site Admin
 
Posts: 2334
Joined: 2008.07.27. 17:00
Location: Hungary

Re: Missing HDD on 2nd Sata Controller

Postby stinklyonion » 2012.10.18. 04:27

Does SSD works better than HDD when it comes to this?
User avatar
stinklyonion
 
Posts: 20
Joined: 2012.10.17. 04:14


Return to Supported Hardware

Who is online

Users browsing this forum: No registered users