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This package must be installed for each user. This package contains a zip file, a Readme file, and an installer script (install.sh) used in the installation process. The installer script will extract the HDSentinel.zip file and do some basic housekeeping.

HDSentinel.zip contains the HDSentinel program, a Readme file, an icon file,  a simple script to launch HDSentinel directly using the gnome-terminal emulator, and a custom launcher to be used with the script. The launch script is very, very basic. It is primarily for folks who are not familiar with scripting and/or are new to Linux. If you know your way around a script, you probably do not need these and can get this done on your own. If you know enough to have a terminal emulator preference, this will be baby steps to you. This is aimed at folks who don't spend a lot of time outside of the GUIs. That said, the package does make installing and using HDSentinel a lot easier.

The launch script automatically generates and saves a report. This feature is already built into HDSentinel with the -r switch. By default HDSentinel saves the report in the same folder as the HDSentinel program, (in this case ~/HDSentinel/) with the name "report.txt", which is overwritten each time "HDSentinel -r" is executed. This means old reports are not saved. The launch script enables the -r switch but alters the naming protocol and saves the report with a filename that includes the creation date and time, so that the reports are easily identified and old reports are saved rather than overwritten.  If the user does not wish to generate a full report, there is a nosave script. It can be launched manually, but it is not installed automatically. The scripts are located at ~/HDSentinel/Gnome/ 

Permissions should be set automatically, but if the launchers do not work properly, you'll need to be sure the permissions are set on the HDSentinel program file to allow executing the file as a program, and also do the same thing for the launch script, and the launcher. 
 

Fedora Cinnamon
You must add yourself to the sudoers file in order to run the installer. After downloading the installer you must set the file to be executable in the Properties>Permissions tab. To do this just right click on the file.
You must also create a new profile in Gnome-Terminal. To do this, open a terminal window (just click on the terminal icon in the Panel). Once you have Gnome-Terminal open, you will have a menu bar at the top of that window. Click on File>New Profile and name your new profile HoldOpen (you must use this name exactly for the scripts to work). Click on the Command tab and set the When command exits box to hold the terminal open.
Now you can click on the installer HDSgnomeXXinstaller.run (where XX is either 32 or 64 depending on your OS) and if you set the file manager to Ask what to do, you should select Run in Terminal.
Installer adds the HDS Icon to the Menu in the Administration section. If you also want to permanently add the Icon to the Panel (task bar at the bottom of screen), right click on the menu Icon and select Add to panel. You can also add it to Favorites this way.
  
Manjaro Gnome and Cinnamon
After downloading the installer you must set the file to be executable in the Properties>Permissions tab. In addition, you must also set some things up in your file manager. File manager does not have a traditional menu bar at the top, but you can set preferences. Right click on Files in the bar at the top of the screen and select preferences. Click on the Behavior tab and in the "Executable Text Files" section, select either "Run executable text files when they are opened" or "Ask each time".
To create a profile for Gnome-Terminal you must first open a terminal window. Click Activities and Terminal is in the Favorites list. Once you have terminal open you will have a menu bar at the top of that window. Click on File>New Profile and name your new profile HoldOpen (you must use this name exactly for the scripts to work).  Click on the Command tab and set the When command exits box to hold the terminal open.
Now you can click on the installer HDSgnomeXXinstaller.run (where XX is either 32 or 64 depending on your OS) and if you set the file manager to Ask what to do, you should select Run in Terminal.
The launcher Icon does not display on the Desktop, but it is in the user's desktop folder. It does display in the Applications Menu (Activities>Show Applications), in the main section. You can drag it to the favorites bar (Activities) or you can right click on the menu icon and select Add to Favorites.  To place the launcher on the desktop, you must use gnome tweak tools. You can access tweak tools from the menu, in the Utilities section. Click on Activities>Show Applications>Utilities>Tweak Tool. Click on Desktop tab on the left and set the Icons on Desktop toggle to ON.

Ubuntu 
After downloading the installer you must set the file to be executable in the Properties>Permissions tab. In addition, you must also set some things up in your file manager. With File manager open you will get a menu bar at the top (visible only when you mouse over it). Click on Edit>Preferences>Behavior tab and in the Executable Text Files section, select either Run executable text files when they are opened or Ask each time.
To create a profile for Gnome-Terminal you must first open a terminal window (to find it you may need to click on the top icon in the Launcher Bar, the Search Icon, and type terminal into the search box). You want the emulator called Terminal, not the ones called UXTerm or XTerm. Once you have terminal open you will have a menu bar(again only visible when you mouse over). Click on Terminal>Preferences>Profiles>New and name your new profile HoldOpen (you must use this name exactly for the scripts to work). Click on the Title and Command Tab (some versions just call it the Command tab) and set the When command exits box to hold the terminal open.
You must manually drag and drop the HDS desktop Icon to the Launcher Bar if you want it there all the time.

Fedora 
You must add yourself to the sudoers file in order to run the installer. After downloading the installer you must set the file to be executable in the Properties>Permissions tab. 
The launcher Icon does not display on the Desktop, but it is in the user's desktop folder. OTOH it does display in the Applications Menu (Activities>Show Applications), in the main section. You can drag it to the favorites bar (Activities) or you can right click on the menu icon and select Add to Favorites. To place the launcher on the desktop, you must first install gnome tweak tools. To install, open a terminal window and type sudo /usr/bin/dnf/ install gnome-tweak-tool and hit enter. You can access tweak tools from the menu, in the Utilities section. Click on Activities>Show Applications>Utilities>Tweak Tool. Click on Desktop tab on the left and set the Icons on Desktop toggle to ON.

Manjaro Budgie 
There is no option in the file manager to set behavior with executable text files as there is in some other Gnome distros. But you can set this (and you need to) using dconf-editor. Hit Alt+F2, type dconf-editor and hit Enter. In dconf-editor go to: org>gnome>nautilus>preferences. Find the executable-text-activation entry (default value is Display). , if it already says Launch or Ask, you're good to go. If it says Display in the value field, click on the word Display. From the drop down menu select either Launch or Ask (I prefer Ask, it means one more click when opening these types of files, but it gives you the option to open it in an editor, which you may want to do with some of these types of files). Close out dconf-editor and run the installer. BTW, if you like to set items to open with a single click, rather than a double click, dconf-editor is where you do that as well. this seems to be the only way to change a number of settings (may be a gnome 3 issue).

Debian Cinnamon 
You must add yourself to the sudoers file in order to run the installer. After downloading the installer you must set the file to be executable in the Properties>Permissions tab. 
The installer fails to add HDS Icon to menu (it does create a menu item but it places it in a user folder not a system folder, while this works best with some distros, it will not work with this one - may be a gnome 2 issue). To add manually you need to use the menu editor. Right click on Menu in lower left corner. Click on Configure. Click on Open the menu editor. Click on System Tools in the left hand column. Click on the New Item button. Name it HDSentinel. Click on Browse and navigate to Home>HDSentinel>Gnome. Select HDSentinel_script_save_gnome and click OK. Click on the Icon place holder (empty square on the left) and navigate to Computer>usr>share>icons, select HDSentinel.png and click OK. Now click OK again, and then Close. There will now be an HDS Icon in the System Tools section of the Menu. If you also want to permanently add the Icon to the Panel (task bar at the bottom of screen), right click on the menu Icon and select Add to panel.

OpenSUSE-Tumbleweed 
After downloading the installer you must set the file to be executable in the Properties>Permissions tab. In addition, you must also set some things up in your file manager. With File manager open you will get a menu bar at the top. Click on Files>Preferences>Behavior tab and in the Executable Text Files section, select either Run executable text files when they are opened or Ask what to do.
To create a profile for Gnome-Terminal you must first open a terminal window,  Activities>Show Applications>Utilities>Terminal (not Xterm). Once you have terminal open you will have a menu bar. Click on File>New Profile and name your new profile HoldOpen (you must use this name exactly for the scripts to work). Click on the Title and Command Tab (some versions just call it the Command tab) and set the When command exits box to hold the terminal open. Close the editing Profile popup and the terminal window. Now you can click on the installer HDSgnomeXXinstaller.run (where XX is either 32 or 64 depending on your OS) and if you set the file manager to Ask what to do, you should select Run in Terminal.
The launcher Icon does not display on the Desktop, but it is in the user's desktop folder. It does display in the Applications Menu (Activities>Show Applications), in the main section. You can drag it to the favorites bar (Activities) or you can right click on the menu icon and select Add to Favorites. To place the launcher on the desktop, you must use gnome tweak tools. You can access tweak tools from the menu, in the Utilities section. Click on Activities>Show Applications>Utilities>Tweak Tool. Click on Desktop tab on the left and set the Icons on Desktop toggle to ON.

Mint Cinnamon 
After downloading the installer you must set the file to be executable in the Properties>Permissions tab. You must also create a profile for Gnome-Terminal. To create a profile for Gnome-Terminal, open a terminal window by clicking on the Terminal Icon in the Panel (taskbar) at the bottom of the screen. Once you have terminal open you will need to get it to display the menu bar. To do this, right click inside the open terminal window, click Show Menubar. Now the menu  bar will be displayed and you can click on File>New Profile and name your new profile HoldOpen (you must use this name exactly for the scripts to work).  and click Create. Click on the Title and Command Tab (some versions just call it the Command tab) and set the When command exits box to hold the terminal open. Close the Editing Profile popup and the terminal window. 
Now you can click on the installer HDSgnomeXXinstaller.run (where XX is either 32 or 64 depending on your OS) and select Run in Terminal. The installer fails to add HDS Icon to the Menu (it does create a menu item but it places it in a user folder not a system folder, while this works best with some distros, it will not work with this one - may be a gnome 2 issue). To add manually you need to use the menu editor. Right click on Menu in lower left corner. Click on Configure. Click on Open the menu editor. Click on System Tools in the left hand column. Click on New Item. Name it HDSentinel. Click on Browse and navigate to Home>HDSentinel>Gnome. Select HDSentinel_script_save_gnome and click OK. Click on the Icon square to the left and navigate to Computer>usr>share>icons, select HDSentinel.png and click OK. Now click OK again, and then Close. There will now be an HDS Icon in the System Tools section of the menu. If you also want to permanently add the Icon to the Panel (task bar at the bottom of screen), right click on the menu Icon and select Add to panel. You can also add it to Favorites this way.

MintDE Cinnamon 
After downloading the installer you must set the file to be executable in the Properties>Permissions tab. You must also create a profile for Gnome-Terminal. To create a profile for Gnome-Terminal, open a terminal window by clicking on the Terminal Icon in the Panel (taskbar) at the bottom of the screen. Once you have terminal open you will need to get it to display the menu bar. To do this, right click inside the open terminal window, click Show Menubar. Now the menu  bar will be displayed and you can click on File>New Profile and name your new profile HoldOpen (you must use this name exactly for the scripts to work).  and click Create. Click on the Title and Command Tab (some versions just call it the Command tab) and set the When command exits box to hold the terminal open. Close the Editing Profile popup and the terminal window. 
Now you can click on the installer HDSgnomeXXinstaller.run (where XX is either 32 or 64 depending on your OS) and select Run in Terminal. Installer adds the HDS Icon to the Menu in the Administration section. If you also want to permanently add the Icon to the Panel (task bar at the bottom of screen), right click on the menu Icon and select Add to panel. You can also add it to Favorites this way.

Zorin Core 
After downloading the installer you must set the file to be executable in the Properties>Permissions tab. You must also create a profile for Gnome-Terminal. To create a profile for Gnome-Terminal, open a terminal window by clicking on the Terminal Icon in the Panel (taskbar) at the bottom of the screen. Once you have terminal open you will have a menu bar. Click on File>New Profile and name your new profile HoldOpen (you must use this name exactly for the scripts to work)  and click Create. Click on the Title and Command Tab (some versions just call it the Command tab) and set the When command exits box to hold the terminal open. Close the Editing Profile popup and the terminal window. 
Now you can click on the installer HDSgnomeXXinstaller.run (where XX is 32 or 64 depending on your OS) and select Run in Terminal.  The Icon will show up on Desktop but you may need to reboot for the Icon to show up in the menu.

CentOS
You must add yourself to the sudoers file in order to run the installer. 
After downloading the installer you must set the file to be executable in the Properties>Permissions tab. You must also create a profile for Gnome-Terminal. To create a profile for Gnome-Terminal, open a terminal window by clicking on the Terminal Icon in the Panel (taskbar) at the bottom of the screen. Once you have terminal open you will need to get it to display the menu bar. To do this, right click inside the open terminal window, click Show Menubar. Now the menu  bar will be displayed and you can click on File>New Profile and name your new profile HoldOpen (you must use this name exactly for the scripts to work) and click Create. Click on the Title and Command Tab (some versions just call it the Command tab) and set the When command exits box to hold the terminal open. Close the Editing Profile popup and the terminal window. 
Now you can click on the installer HDSgnomeXXinstaller.run (where XX is 32 or 64 depending on your OS) and select Run in Terminal. Installer adds the HDS Icon to the Menu in the System Tools section. If you also want to permanently add the Icon to the Panel (task bar at the top of screen), right click on the menu Icon and select Add to panel. 

